

<!DOCTYPE html >
<html lang="en"  xmlns:fb="http://ogp.me/ns/fb#"> 
<head>
	
	<!-- Load Story -->
	
	

<script>var setupRequestType = "StoryPage";</script>

<!-- Begin: MetaTags -->



<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge"> 
<meta name="viewport" content="width=device-width, initial-scale=1">



	
	<meta property="fb:app_id" content="205815426131136" />
	<meta property="og:title" content="Giants trade Beckham to Browns, Jets get Bell" />
	<meta property="og:type" content="article" />
	<meta property="og:site_name" content="KSTP" />
	<meta property="og:description" content="" />
	<meta property="og:url" content="https://kstp.com/sports/another-receiver-megadeal-giants-trade-beckham-to-browns/5276867/" />
	
	<meta name="DC.date.issued" content="2019-03-13">

    <meta name="twitter:card" content="summary_large_image">
    <meta name="twitter:site" content="@KSTP">
    <meta name="twitter:title" content="Giants trade Beckham to Browns, Jets get Bell">
    <meta name="twitter:description" content="">
	
    	<meta name="twitter:image" content="https://kstp.com/APImages/APca600d68e42e4fde8346f713ec2e0d3a.jpg">
	
			
			
			<meta property="og:image" content="https://kstp.com/APImages/APca600d68e42e4fde8346f713ec2e0d3a.jpg" />
			<meta property="og:image:width" content="512" /> <meta property="og:image:height" content="341" />
			<link rel="image_src" type="image/jpeg" href="https://kstp.com/APImages/APca600d68e42e4fde8346f713ec2e0d3a.jpg" />
			<meta name="thumbnail" content="https://kstp.com/APImages/APca600d68e42e4fde8346f713ec2e0d3a.jpg" />
			
			
		
		<meta http-equiv="Refresh" content=900 />
	
	<meta name="robots" content="FOLLOW,INDEX" />

	<link rel="canonical" href="https://kstp.com/sports/another-receiver-megadeal-giants-trade-beckham-to-browns/5276867/" />

	<link rel="amphtml" href="https://amp.kstp.com/articles/another-receiver-megadeal-giants-trade-beckham-to-browns-5276867.html"> 





<link rel="icon" type="image/png"  href="/kstpimages/favicons/apple-touch-icon-57x57.png">

<link rel="apple-touch-icon" sizes="57x57" href="/kstpimages/favicons/apple-touch-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="/kstpimages/favicons/apple-touch-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="/kstpimages/favicons/apple-touch-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="/kstpimages/favicons/apple-touch-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="/kstpimages/favicons/apple-touch-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="/kstpimages/favicons/apple-touch-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="/kstpimages/favicons/apple-touch-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="/kstpimages/favicons/apple-touch-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="/kstpimages/favicons/apple-touch-icon-180x180.png">
<link rel="icon" type="image/png" href="/kstpimages/favicons/favicon-32x32.png" sizes="32x32">
<link rel="icon" type="image/png" href="/kstpimages/favicons/favicon-194x194.png" sizes="194x194">
<link rel="icon" type="image/png" href="/kstpimages/favicons/favicon-96x96.png" sizes="96x96">
<link rel="icon" type="image/png" href="/kstpimages/favicons/android-chrome-192x192.png" sizes="192x192">
<link rel="icon" type="image/png" href="/kstpimages/favicons/favicon-16x16.png" sizes="16x16">
<link rel="manifest" href="/kstpimages/favicons/manifest.json">
<link rel="mask-icon" href="/kstpimages/favicons/safari-pinned-tab.svg" color="#5bbad5">
<meta name="msapplication-TileColor" content="#da532c">
<meta name="msapplication-TileImage" content="/kstpimages/favicons/mstile-144x144.png">
<meta name="theme-color" content="#ffffff">

<meta name="apple-itunes-app" content="app-id=546024067">
<meta name="google-play-app" content="com.doapps.android.mln.MLN_fe2672296a661b7acdf9fe36f27e7a55">

<!-- End: MetaTags -->

    <script type="application/ld+json">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</script>

		

<link rel="stylesheet" type="text/css" href="/assets/css/hubbard-min.css">
<link rel="stylesheet" type="text/css" href="/assets/css/brand.css">
<link rel="stylesheet" type="text/css" href="/assets/css/hbi.css">
<script type="text/javascript" src="/assets/js/bower.js"></script>
<script type="text/javascript" src="/assets/js/hubbard-min.js"></script>
<script src='//www.google.com/jsapi' type='text/javascript'></script> <!-- Google Search --->
<script type="text/javascript" src="/assets/js/DFP-DebugFlag.js"></script>
<script type="text/javascript" src="/2016/widgets/2016-WXWIDGET.js"></script>
<script type="text/javascript" src="/assets/js/DFP-VirtualDirectories.js"></script>
<script type="text/javascript" src="/assets/js/DFP-SEOSlugs.js"></script>
<script type="text/javascript" src="/assets/js/DFP-ExtractCategory.js"></script>
<script type="text/javascript" src="/assets/js/DFP-CatAdUnitWeb24.2016.js"></script>
<script type="text/javascript" src="/assets/js/DFP-OverrideAdUnitWeb24.2016.js"></script>
<script type="text/javascript" src="/assets/js/DFP-CatAllowTagsWeb24.2016.js"></script>
<script type="text/javascript" src="/2016/scripts/leaderboardOverride.js"></script>
<script type="text/javascript" src="/assets/js/DFP-Header.js"></script>
<script type="text/javascript" src="/2016/widgets/HBI-weatherWidgetDefault.js"></script>
<script type="text/javascript" src="/assets/js/HBI-weatherWidget.js"></script>
<script type="text/javascript" src="/assets/js/HBI-storyTimes.js"></script>
<script type="text/javascript" src="/assets/js/ANVATO-Setup-Script.js"></script>
<script type="text/javascript" src="/2016/scripts/ANVATO-Setup-Category-Xref-Playlist.js"></script>

<!-- Begin WSI Interactive Radar loader script -->
<!-- <script type="text/javascript" src="https://webwidgets.wsi.com/wxwidget.loader.js?cid=654566225"></script> -->
<!-- <script type="text/javascript" src="http://webwidgets.wsi.com/?cid=654566225"></script> -->
<!-- End WSI Interactive Radar loader script -->

<!-- BEGIN ABC -->
<script language="JavaScript1.2" src="/2016/scripts/viewABC.js"></script>
<!--  Removed on 07/19/2017 - We are getting a Error 503 Service Unavailable.
	<script type="text/javascript" src="http://cdn.abc.go.com/vp2/s/deeplinkjs?aff=kstp"></script> 
-->
<!-- END ABC -->
        <!-- BEGIN: 2016-3rd-Party-Header -->
<!-- Begin Ads By Google Script - 11/10/2016 -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-5958923341480860",
    enable_page_level_ads: true
  });
</script>
<!-- End Ads By Google Script - 11/10/2016 -->

<!-- END: 2016-3rd-Party-Header -->

        
    
	    <title>Giants trade Beckham to Browns, Jets get Bell | KSTP.com</title>
	
</head>
<body>

<!-- Main Navigation -->
<header class="header-top">
	
<!-- Topbar (Rushmore) -->

  <div class="topbar visible-md visible-lg">
    <div class="row">
      <div class="col-xs-12">
        <a class="pull-left" href="/">
          <img alt="KSTP.com 5 Eyewitness News" class="logo" src="/assets/images/weblogos.png">
        </a>
        
	        <!-- Start: 2016-WEATHER-WIDGET-DESK -->
<a href="/weather/">
<div id="desktopWeatherWidget" class="pull-right hidden-xs hidden-sm hbi-weather-widget-dsk">
	<div class="row">
		<div class="col-xs-4">
            <div class="row">
                <div class="col-xs-3 hbi-weather-widget-align hbi-weather-widget-icon-desk" id="currIconDesk"></div>        		
                <div class="col-xs-4 hbi-weather-widget-align hbi-weather-widget-temp-desk" id="currTempDesk"></div>        		
                <div class="col-xs-5 hbi-weather-widget-vari-desk text-nowrap" id="currVariDesk">
	                Feels like: <span id="currFeelsLike"></span>
                    <br />Humidity: <span id="currHumidity"></span>
                    <br />Wind: <span id="currWindSpeed"></span>
                </div>        		
			</div>
            <div class="row">
                <div class="col-xs-12 hbi-weather-widget-desc-desk text-center" id="currDescDesk"></div>        		
			</div>
        </div>
		<div class="col-xs-1">
		</div>
		<div class="col-xs-4">
            <div class="row">
                <div class="col-xs-6">
                    <div class="row">
                        <div class="col-xs-6 hbi-weather-widget-align hbi-weather-widget-icon1-desk" id="secondIconDesk"></div>        		
                        <div class="col-xs-6 hbi-weather-widget-align hbi-weather-widget-desc1-desk" id="secondTempDesk"></div>        		
                    </div>
                </div>
                <div class="col-xs-6">
                    <div class="row">
                        <div class="col-xs-6 hbi-weather-widget-align hbi-weather-widget-icon1-desk" id="thirdIconDesk"></div>        		        <div class="col-xs-6 hbi-weather-widget-align hbi-weather-widget-desc1-desk" id="thirdTempDesk"></div>                    </div>
                </div>
			</div>
             <div class="row">
                <div class="col-xs-12 hbi-weather-widget-sponsord">
					<div id="WXWIDGET" class="col-xs-12 text-center">
<script>googletag.cmd.push(function() {googletag.display('WXWIDGET');});</script> 
</div>

                </div>
             </div>
        </div>    
		<div class="col-xs-3">
            <div class="row">
                <div class="col-xs-6 hbi-weather-widget-align hbi-weather-widget-icon-desk" id="tomorrowIconDesk"></div>        		
                <div class="col-xs-6 hbi-weather-widget-align hbi-weather-widget-desc2-desk">
                	<div>Tomorrow</div>
                    <div id="tomorrowTempDesk"></div>
                </div>        		
			</div>
        </div>
    </div>
</div>
</a>
<!-- End: 2016-WEATHER-WIDGET-DESK -->

                    
      </div>
    </div>
  </div>
  <!-- Close Topbar -->
<!-- Start: NAV-DESK -->
  <nav class="navbar navbar-default navbar-desktop visible-md visible-lg">
    <!-- Main Menu -->
    <ul class="nav navbar-nav navbar-left">
        
            <!-- BEGIN: News -->
<li>
<a class="text-uppercase" href="/topstories/">News</a>
<div class="dropdown-menu">
	<div class="row">
		<div class="col-md-3">
			<ul class="list-unstyled list-lg-space">
				<li><a href="/topstories" class="hbi-nav-a" target="_self">Top Stories</a></li>
				<li><a href="/local" class="hbi-nav-a" target="_self">Local</a></li>
				<li><a href="/national" class="hbi-nav-a" target="_self">National</a></li>
				<li><a href="/entertainment" class="hbi-nav-a" target="_self">Entertainment</a></li>
				<li><a href="/politics" class="hbi-nav-a" target="_self">Politics</a></li>
				<li><a href="/business" class="hbi-nav-a" target="_self">Business</a></li>
				<li><a href="/medical" class="hbi-nav-a" target="_self">Medical</a></li>
				<li><a href="/technology" class="hbi-nav-a" target="_self">Technology</a></li>
			</ul>
		</div>
		<div class="col-md-3">
			<p><a href="/news/non-profit-provides-legal-aid-to-kids-in-child-protective-services/5278402/?cat=1"><img class="img-responsive" src="/kstpImages/repository/2019-03/800ChildrensLawKSTP.jpg" alt="Non-profit provides legal aid to kids in child protective services" width="270"></a></p>
			<p><a href="/news/non-profit-provides-legal-aid-to-kids-in-child-protective-services/5278402/?cat=1">Non-profit provides legal aid to kids in child protective services</a></p>
		</div>
		<div class="col-md-3">
			<p><a href="/news/amber-alert-suspect-in-custody-girl-may-be-in-minnesota-or-michigan-wdio/5278410/?cat=1"><img class="img-responsive" src="/kstpImages/repository/2019-03/800AmberAlertBabyWISN.jpg" alt="Amber Alert: Suspect in custody, girl may be in Minnesota or Michigan" width="270"></a></p>
			<p><a href="/news/amber-alert-suspect-in-custody-girl-may-be-in-minnesota-or-michigan-wdio/5278410/?cat=1">Amber Alert: Suspect in custody, girl may be in Minnesota or Michigan</a></p>
		</div>
		<div class="col-md-3">
			<hr class="margin-top-bottom-sm margin-top-none">
			<p><a href="/news/rain-on-top-of-snow-makes-for-messy-commute-in-the-twin-cities/5278334/?cat=1">Rain on top of snow makes for messy commute in the Twin Cities</a></p>
			<hr class="margin-top-bottom-sm margin-top-none">
			<p><a href="/weather/more-rain-to-soak-up-thursday-turning-to-snow-in-evening-hours/5278362/?cat=1">More rain to soak up Thursday, rain to snow mix late</a></p>
			<hr class="margin-top-bottom-sm margin-top-none">
			<p><a href="/news/minnesota-fraud-investigators-testify-allege-108m-in-taxpayer-financed-child-daycare-fraud/5278338/?cat=1">Minnesota fraud investigators testify, allege $108M in taxpayer-financed child daycare fraud</a></p>
			<h4 class="text-uppercase text-right text-muted">
			<a href="/topstories/">More News Stories</a>
			<span class="glyphicon glyphicon-menu-right"></span>
			</h4>
		</div>
	</div>
</div>
</li>
<!-- END: News -->
<!-- BEGIN: Weather -->
<li>
<a class="text-uppercase" href="/weather/">Weather</a>
<div class="dropdown-menu">
	<div class="row">
		<div class="col-md-3">
			<ul class="list-unstyled list-lg-space">
				<li><a href="/interactiveradar/?cat=3" class="hbi-nav-a" target="_self">Interactive Radar</a></li>
				<li><a href="/article/13067/?cat=3" class="hbi-nav-a" target="_self">Forecast</a></li>
				<li><a href="/schoolalert/" class="hbi-nav-a" target="_self">School Alert</a></li>
				<li><a href="/pages/weather/weather-images/temps-map-state.shtml/?cat=3" class="hbi-nav-a" target="_self">Temperatures</a></li>
				<li><a href="/outdoors/?cat=3" class="hbi-nav-a" target="_self">Outdoors</a></li>
			</ul>
		</div>
		<div class="col-md-3">
			<p><a href="/weather/" target=""><img class="img-responsive" src="/kstpimages/wx/web_7day.jpg" width="270"></a></p>
<p><a href="/weather/" target="">7-Day Forecast</a>
		</div>
		<div class="col-md-3">
			<p><a href="/article/11350/" target=""><img class="img-responsive" src="/kstpImages/wx/mdwradar5_2.jpg" width="270"></a></p>
<p><a href="/article/11350/" target="">Regional Radar</a>
		</div>
		<div class="col-md-3">
			<hr class="margin-top-bottom-sm margin-top-none">
			<p><a href="/weather/more-rain-to-soak-up-thursday-turning-to-snow-in-evening-hours/5278362/?cat=150">More rain to soak up Thursday, rain to snow mix late</a></p>
			<hr class="margin-top-bottom-sm margin-top-none">
			<p><a href="/news/blizzard-conditions-flooding-concerns-in-upper-midwest/5277224/?cat=150">Blizzard conditions, flooding concerns in Upper Midwest</a></p>
			<hr class="margin-top-bottom-sm margin-top-none">
			<p><a href="/weather/rain-arrives-fog-advisory-and-flood-watch-active-for-wednesday/5276880/?cat=150">Rain arrives, fog advisory and flood watch active for Wednesday</a></p>
			<h4 class="text-uppercase text-right text-muted">
			<a href="/weather/">More Weather Stories</a>
			<span class="glyphicon glyphicon-menu-right"></span>
			</h4>
		</div>
	</div>
</div>
</li>
<!-- END: Weather -->
<!-- BEGIN: Traffic -->
<li>
<a class="text-uppercase" href="/traffic/">Traffic</a>
<div class="dropdown-menu">
	<div class="row">
		<div class="col-md-3">
			<ul class="list-unstyled list-lg-space">
				<li><a href="/pages/traffic/traffic-map.shtml" class="hbi-nav-a" target="_self">Traffic Map</a></li>
				<li><a href="/traffic/" class="hbi-nav-a" target="_self">Top Stories</a></li>
			</ul>
		</div>
		<div class="col-md-3">
			<p><a href="/pages/traffic/traffic-map.shtml" target=""><img class="img-responsive" src="/kstpImages/800TrafficMapGraphicNavigation.jpg" width="270"></a></p>
<p><a href="/traffic/" target="">Traffic Map</a>
		</div>
		<div class="col-md-3">
			<p><a href="/article/11350/" target=""><img class="img-responsive" src="/kstpImages/wx/mdwradar5_2.jpg" width="270"></a></p>
<p><a href="/article/11350/" target="">Regional Radar</a>
		</div>
		<div class="col-md-3">
			<hr class="margin-top-bottom-sm margin-top-none">
			<p><a href="/traffic/freezing-drizzle-dense-fog-slick-roads-wednesday-morning-commute-traffic-report/5277184/?cat=12546">Wet roads, lingering fog to complicate Wednesday AM commute</a></p>
			<hr class="margin-top-bottom-sm margin-top-none">
			<p><a href="/news/state-patrol-investigates-fatal-crash-burnsville/5275168/?cat=12546">State Patrol investigates fatal crash in Burnsville</a></p>
			<hr class="margin-top-bottom-sm margin-top-none">
			<p><a href="/news/rash-of-potholes-opens-up-on-metro-roads/5274862/?cat=12546">Rash of potholes opens up on metro roads</a></p>
			<h4 class="text-uppercase text-right text-muted">
			<a href="/traffic/">More Traffic Stories</a>
			<span class="glyphicon glyphicon-menu-right"></span>
			</h4>
		</div>
	</div>
</div>
</li>
<!-- END: Traffic -->
<!-- BEGIN: Investigative -->
<li>
<a class="text-uppercase" href="/investigative">Investigative</a>
<div class="dropdown-menu">
	<div class="row">
		<div class="col-md-3">
			<ul class="list-unstyled list-lg-space">
				<li><a href="/article/12420/" class="hbi-nav-a" target="_self">Top Stories</a></li>
				<li><a href="/in-depth/" class="hbi-nav-a" target="_self">In-Depth</a></li>
				<li><a href="/pages/misc-pages/send-us-your-news-tip.shtml" class="hbi-nav-a" target="_self">Send Us Tips</a></li>
			</ul>
		</div>
		<div class="col-md-3">
			<p><a href="/news/tim-walz-minnesota-governor-responds-sex-lies-disgrace-national-guard-officer-conduct/5261706/?cat=5"><img class="img-responsive" src="/kstpImages/repository/2019-02/800sexliesdisgracereportgraphic-kstptv-1.jpg" alt="Walz responds to 5 EYEWITNESS NEWS investigation into conduct of high-ranking National Guard officer" width="270"></a></p>
			<p><a href="/news/tim-walz-minnesota-governor-responds-sex-lies-disgrace-national-guard-officer-conduct/5261706/?cat=5">Walz responds to 5 EYEWITNESS NEWS investigation into conduct of high-ranking National Guard officer</a></p>
		</div>
		<div class="col-md-3">
			<p><a href="/news/house-bill-would-require-pet-owners-to-microchip-animals-to-obtain-opioids/5258610/?cat=5"><img class="img-responsive" src="/kstpImages/repository/2019-02/800MicrochippedPets.jpg" alt="House bill would require pet owners to microchip animals to obtain opioids" width="270"></a></p>
			<p><a href="/news/house-bill-would-require-pet-owners-to-microchip-animals-to-obtain-opioids/5258610/?cat=5">House bill would require pet owners to microchip animals to obtain opioids</a></p>
		</div>
		<div class="col-md-3">
			<hr class="margin-top-bottom-sm margin-top-none">
			<p><a href="/news/sex-lies-and-disgrace-the-honorable-discharge-of-a-commander-in-minnesotarsquos-national-guard/5254001/?cat=5">Sex, lies and disgrace: The honorable discharge of a commander in Minnesota&rsquo;s National Guard</a></p>
			<hr class="margin-top-bottom-sm margin-top-none">
			<p><a href="/news/changing-how-they-chase-most-officers-in-minnesota-are-forced-to-make-judgment-calls-behind-the-wheel/5250139/?cat=5">Changing how they chase: Most officers in Minnesota are forced to make judgment calls behind the wheel</a></p>
			<hr class="margin-top-bottom-sm margin-top-none">
			<p><a href="/news/days-before-super-bowl-52-mall-of-america-executive-suggested-sending-homeless-away-with-a-happy-meal-/5233868/?cat=5">Days before Super Bowl 52, Mall of America executive suggested sending homeless away with &#39;a Happy Meal&#39;</a></p>
			<h4 class="text-uppercase text-right text-muted">
			<a href="/investigative">More Investigative Stories</a>
			<span class="glyphicon glyphicon-menu-right"></span>
			</h4>
		</div>
	</div>
</div>
</li>
<!-- END: Investigative -->
<!-- BEGIN: Sports -->
<li>
<a class="text-uppercase" href="/sports">Sports</a>
<div class="dropdown-menu">
	<div class="row">
		<div class="col-md-3">
			<ul class="list-unstyled list-lg-space">
				<li><a href="/article/12688" class="hbi-nav-a" target="_self">Top Stories</a></li>
				<li><a href="/vikings" class="hbi-nav-a" target="_self">Vikings</a></li>
				<li><a href="/wild" class="hbi-nav-a" target="_self">Wild</a></li>
				<li><a href="/twins" class="hbi-nav-a" target="_self">Twins</a></li>
				<li><a href="/pages/sports/timberwolves-and-lynx.shtml" class="hbi-nav-a" target="_self">Timberwolves / Lynx</a></li>
				<li><a href="/article/13150/" class="hbi-nav-a" target="_self">Minnesota United</a></li>
				<li><a href="/collegesports" class="hbi-nav-a" target="_self">College Sports</a></li>
				<li><a href="/highschoolsports" class="hbi-nav-a" target="_self">High School Sports</a></li>
			</ul>
		</div>
		<div class="col-md-3">
			<p><a href="/sports/gophers-softball-team-trachsel-fiser-series-win-texas/5277828/?cat=7"><img class="img-responsive" src="/kstpImages/repository/2019-03/Gophers_softball_team_off_to_good_start_after_series_win_at_top10_Texas-syndImport-012520.jpg" alt="Gophers ace Amber Fiser talked to KSTP's Chris Long this week." width="270"></a></p>
			<p><a href="/sports/gophers-softball-team-trachsel-fiser-series-win-texas/5277828/?cat=7">Gophers softball team off to good start after series win at top-10 Texas</a></p>
		</div>
		<div class="col-md-3">
			<p><a href="/sports/minnesota-state-girls-basketball-tournament-central-page/5274984/?cat=7"><img class="img-responsive" src="/kstpImages/repository/2019-03/mtr-basketball-girls-tournament-cropped.jpg" alt="Girls&#39; State Basketball Tournament Central" width="270"></a></p>
			<p><a href="/sports/minnesota-state-girls-basketball-tournament-central-page/5274984/?cat=7">Girls&#39; State Basketball Tournament Central</a></p>
		</div>
		<div class="col-md-3">
			<hr class="margin-top-bottom-sm margin-top-none">
			<p><a href="/sports/nuggets-beat-timberwolves-133-107-tuesday-march-12-2019/5277297/?cat=7">Murray leads charge as Nuggets beat Timberwolves 133-107</a></p>
			<hr class="margin-top-bottom-sm margin-top-none">
			<p><a href="/sports/kstp-sports-2019-boys-state-hockey-tournament-central/5264722/?cat=7">KSTP Sports 2019 Boys&#39; State Hockey Tournament Central</a></p>
			<hr class="margin-top-bottom-sm margin-top-none">
			<p><a href="/sports/lakeville-north-junior-lauren-jensen-records-girls-basketball-state-tournament/5276085/?cat=7">Lakeville North junior already in elite company</a></p>
			<h4 class="text-uppercase text-right text-muted">
			<a href="/sports">More Sports Stories</a>
			<span class="glyphicon glyphicon-menu-right"></span>
			</h4>
		</div>
	</div>
</div>
</li>
<!-- END: Sports -->
<!-- BEGIN: 5 Take Action -->
<li><a class="text-uppercase" href="/5takeaction">5 Take Action</a></li>
<!-- END: 5 Take Action -->
<!-- BEGIN: Digital Extras -->
<li>
<a class="text-uppercase" href="/digitalextras">Digital Extras</a>
<div class="dropdown-menu">
	<div class="row">
		<div class="col-md-3">
			<ul class="list-unstyled list-lg-space">
				<li><a href="/livevideo" class="hbi-nav-a" target="_self">Live Video</a></li>
				<li><a href="/video" class="hbi-nav-a" target="_self">On-Demand Video</a></li>
				<li><a href="/photogalleries" class="hbi-nav-a" target="_self">Photo Galleries</a></li>
				<li><a href="/alertsandapps" class="hbi-nav-a" target="_self">Alerts & App</a></li>
				<li><a href="/links/" class="hbi-nav-a" target="_blank">As Seen on 5 Eyewitness News</a></li>
			</ul>
		</div>
		<div class="col-md-3">
			<p><a href="/minnesota-moment/minnesota-moment-corpse-flower-expected-to-bloom-soon-at-u-of-m/5278419/?cat=12157"><img class="img-responsive" src="/kstpImages/repository/2019-03/800FlowerKSTP.jpg" alt="Minnesota Moment: Corpse flower expected to bloom soon at U of M" width="270"></a></p>
			<p><a href="/minnesota-moment/minnesota-moment-corpse-flower-expected-to-bloom-soon-at-u-of-m/5278419/?cat=12157">Minnesota Moment: Corpse flower expected to bloom soon at U of M</a></p>
		</div>
		<div class="col-md-3">
			<p><a href="/news/full-newscast-5-eyewitness-news-at-10-tuesday-/5277393/?cat=12157"><img class="img-responsive" src="/kstpImages/repository/2019-03/5EWN-10-800X450.jpg" alt="FULL NEWSCAST: 5 EYEWITNESS NEWS at 10 Tuesday" width="270"></a></p>
			<p><a href="/news/full-newscast-5-eyewitness-news-at-10-tuesday-/5277393/?cat=12157">FULL NEWSCAST: 5 EYEWITNESS NEWS at 10 Tuesday</a></p>
		</div>
		<div class="col-md-3">
			<hr class="margin-top-bottom-sm margin-top-none">
			<p><a href="/news/full-sportscast-5-eyewitness-news-at-10-tuesday-/5277392/?cat=12157">FULL SPORTSCAST: 5 EYEWITNESS NEWS at 10 Tuesday</a></p>
			<hr class="margin-top-bottom-sm margin-top-none">
			<p><a href="/minnesota-moment/minnesota-moment-next-generation-leaders-provided-boost-for-education/5276913/?cat=12157">Minnesota Moment: Next generation leaders provided boost for education</a></p>
			<hr class="margin-top-bottom-sm margin-top-none">
			<p><a href="/news/10-pm-full-newscast-5-eyewitness-news-monday-march-11-2019/5275935/?cat=12157">FULL NEWSCAST: 5 EYEWITNESSNEWS at 10 Monday</a></p>
			<h4 class="text-uppercase text-right text-muted">
			<a href="/digitalextras">More Digital Extras Stories</a>
			<span class="glyphicon glyphicon-menu-right"></span>
			</h4>
		</div>
	</div>
</div>
</li>
<!-- END: Digital Extras -->
<!-- BEGIN: KSTP TV -->
<li>
<a class="text-uppercase" href="/article/21/">KSTP TV</a>
<div class="dropdown-menu">
	<div class="row">
		<div class="col-md-3">
			<ul class="list-unstyled list-lg-space">
				<li><a href="/tvschedule" class="hbi-nav-a" target="_self">Programming</a></li>
				<li><a href="http://abc.go.com/?aff=kstp" class="hbi-nav-a" target="_blank">ABC Programming</a></li>
				<li><a href="/atissue" class="hbi-nav-a" target="_self">At Issue</a></li>
				<li><a href="http://twincitieslive.com/" class="hbi-nav-a" target="_blank">Twin Cities Live</a></li>
				<li><a href="http://kstc45.com/" class="hbi-nav-a" target="_blank">45TV</a></li>
			</ul>
		</div>
		<div class="col-md-3">
			<p><a href="/newsteam/" target=""><img class="img-responsive" src="/2016/misc/navigationAM.jpg" width="270"></a></p>
<p><a href="/newsteam/" target="">5 Eyewitness News Mornings</a>
		</div>
		<div class="col-md-3">
			<p><a href="/newsteam/" target=""><img class="img-responsive" src="/2016/misc/navigationPM.jpg" width="270"></a></p>
<p><a href="/newsteam/" target="">5 Eyewitness News at 10PM</a>
		</div>
		<div class="col-md-3">
			<p><strong>Coming Up:</strong></p>
<hr class="margin-top-bottom-sm margin-top-none">
<p>12:07 am: Pawn Stars</p>
<hr class="margin-top-bottom-sm margin-top-none">
<p>12:37 am: Twin Cities Live</p>
<hr class="margin-top-bottom-sm margin-top-none">
<p>1:37 am: Twin Cities Live @ Four</p>
<hr class="margin-top-bottom-sm margin-top-none">
<p>2:07 am: Shopper's Showcase</p>
<hr class="margin-top-bottom-sm margin-top-none">
<h4 class="text-uppercase text-right text-muted">
<a href="/article/21/">Full On-Air Schedule</a>
<span class="glyphicon glyphicon-menu-right"></span>
</h4>
		</div>
	</div>
</div>
</li>
<!-- END: KSTP TV -->
<!-- BEGIN: Links -->
<li>
<a class="text-uppercase" href="/links/">Links</a>
<div class="dropdown-menu">
	<div class="row">
		<div class="col-md-3">
			<ul class="list-unstyled list-lg-space">
				<li><a href="/article/24/" class="hbi-nav-a" target="_self">Outreach and Events</a></li>
				<li><a href="/contests/" class="hbi-nav-a" target="_self">Contests</a></li>
				<li><a href="http://twincitieslive.com/article/12491/" class="hbi-nav-a" target="_blank">What's Happening This Weekend?</a></li>
			</ul>
		</div>
		<div class="col-md-3">
			<p><strong>Quick Links:</strong></p>
<hr class="margin-top-bottom-sm margin-top-none">
<p><a href="https://kstp.com/news/minneapolis-school-bus-driver-saves-toddler-from-harsh-winter-conditions/5276912/">Minneapolis school bus driver saves toddler from harsh winter conditions</a></p>
<hr class="margin-top-bottom-sm margin-top-none">
<p><a href="https://kstp.com/news/red-wing-readies-for-potential-flooding-from-snow-melt-and-rainfall/5275455/">Red Wing readies for potential flooding from snow melt and rainfall</a></p>
<hr class="margin-top-bottom-sm margin-top-none">
<p><a href="https://www.ag.state.mn.us/Office/Complaint.asp" target='_blank'>MN Attorney General: File a Tech Scam Complaint</a></p>
<hr class="margin-top-bottom-sm margin-top-none">
<p><a href="https://kstp.com/news/family-boosting-efforts-to-find-missing-stillwater-man/5270127/">Family boosting its efforts to find missing Stillwater man</a></p>
<hr class="margin-top-bottom-sm margin-top-none">
<h4 class="text-uppercase text-right text-muted">
<a href="/links/">More Links</a>
<span class="glyphicon glyphicon-menu-right"></span>
</h4>
		</div>
		<div class="col-md-3">
			<p><a href="/pages/misc-pages/send-us-your-technical-question-or-issue.shtml" target=""><img class="img-responsive" src="/2016/misc/rescan270x152.jpg" width="270"></a></p>
<p><a href="/pages/misc-pages/send-us-your-technical-question-or-issue.shtml" target="">Help with Rescan</a>
		</div>
		<div class="col-md-3">
			<p><a href="/pages/misc-pages/mobile-apps.shtml"><img class="img-responsive" src="/kstpImages/250KSTPAppGraphic.jpg" width="270"></a></p>
<p><a href="/pages/misc-pages/mobile-apps.shtml">Download the KSTP App</a>
		</div>
	</div>
</div>
</li>
<!-- END: Links -->
<!-- BEGIN: Contact Us -->
<li>
<a class="text-uppercase" class="hbi-nav-a" href="/pages/misc-pages/contact-5-eyewitness-news.shtml">Contact Us</a>
<div class="dropdown-menu">
	<div class="row">
		<div class="col-md-3"></div>
		<div class="col-md-3">
			<p><a href="/newsteam">News Team</a></p>
			<hr class="margin-top-bottom-sm">
			<p><a href="/pages/misc-pages/send-us-your-news-tip.shtml">Submit a News Tip</a></p>
			<hr class="margin-top-bottom-sm">
			<p><a href="/pages/misc-pages/contact-5-eyewitness-news.shtml">Submit a Question</a></p>
			<hr class="margin-top-bottom-sm">
		</div>
		<div class="col-md-3">
			<p><a href="/pages/misc-pages/hubbard-broadcasting-stations.shtml">HBI Properties</a></p>
			<hr class="margin-top-bottom-sm">
			<p><a href="https://hubbardbroadcasting.com/">Careers</a></p>
			<hr class="margin-top-bottom-sm">
			<p><a href="/pages/misc-pages/send-us-your-advertising-request-or-question.shtml/">Advertise with Us</a></p>
			<hr class="margin-top-bottom-sm">
		</div>
		<div class="col-md-3"></div>
	</div>
</div>
</li>
<!-- END: Contact Us -->


            
    </ul>
    <!-- Close Main Menu -->

    <!-- Navbar Right -->
				<!-- Begin CloudSearch Button -->
			<a href='/article/12675/'>
				<button style="vertical-align:middle; width: 32px; float:right; position: relative; margin-top: 8px;">
					<span class='glyphicon glyphicon-search'></span>
				</button>
			</a>
		<!-- End CloudSearch Button -->

    <!-- Close Navbar Right -->
  </nav>
<!-- End: NAV-DESK -->

	<!-- Start: NAV-MOBI scroll -->
  <!-- Mobile Nav -->
  <nav id="sticky-header" class="navbar navbar-default navbar-desktop navbar-fixed-top navbar-fixed-offscreen">
	<!-- Begin CloudSearch Button -->
	<div style='position: relative; z-index: 100;'>
		<a href='/article/12675/'>
			<button style="vertical-align:middle; width: 32px; float:right; position: relative; margin-top: 8px;">
				<span class='glyphicon glyphicon-search'></span>
			</button>
		</a>
	</div>
	<!-- End CloudSearch Button -->
    
    <!-- Navbar Header -->
    <div class="navbar-header">
	  <!-- WW01 - To center the weather widget on iphone -->
      <!-- Mobile Only Menu Button -->
      <a class="navbar-brand" href="/">
        <img alt="KSTP.com 5 Eyewitness News" src="/assets/images/weblogosMobile.png">
      </a>
	  <!-- end WW01-->
      
      <!-- Mobile Only Menu Button -->
      <a class="mega-nav-btn btn btn-link pull-right mobile-menu-button visible-xs" href="#">
        MENU
        <span class="glyphicon glyphicon-menu-hamburger"></span>
        <span class="glyphicon glyphicon-remove hidden"></span>
      </a>
      
          <!-- Small Weather Widget -->
	 	<!-- Start: 2016-WEATHER-WIDGET-MOB -->
<div id="mobileWeatherWidget" class="hidden-sm hidden-md hidden-lg hbi-weather-widget-mob">
	<div class="row">
		<div class="col">
            <div class="row">
				<a href="/weather/" class="weatherMobileWidget">
                <div class="col-xs-6 col-sm-2 hbi-weather-widget-align hbi-weather-widget-icon-mob" id="currIconMob"></div>        		
                <div class="col-xs-6 col-sm-2 hbi-weather-widget-align hbi-weather-widget-temp-mob" id="currTempMob"></div>        		
				</a>
			</div>
        </div>
    </div>    
</div>
<!-- End: 2016-WEATHER-WIDGET-MOB -->
    	<!-- Close Small Weather Widget -->

    </div>
    <!-- Close Navbar Header -->

    <!-- Small Weather Widget -->
 	<!-- Start: 2016-WEATHER-WIDGET-TAB -->
<div id="TableWeatherWidget" class="center-block hidden-xs  hbi-weather-widget-tab">
	<div class="row">
		<div class="col">
            <div class="row">
				<a href="/weather/">
                <div id="currIconTab" class="col-sm-3 hbi-weather-widget-align hbi-weather-widget-icon-tab"></div>        		
                <div id="currTempTab" class="col-sm-3 hbi-weather-widget-align hbi-weather-widget-temp-tab"></div>        		
                <div id="currDescTab" class="col-sm-6 hbi-weather-widget-align hbi-weather-widget-desc-tab"></div>        		
				</a>
        	</div>
        </div>
    </div>    
</div>
<!-- End: 2016-WEATHER-WIDGET-TAB -->

    <!-- Close Small Weather Widget -->

    <!-- Search Box -->
    <div class="navbar-search">
      <div class="input-group">
        <!-- BEGIN GOOGLE SEARCH BOX -->

<script>
	(function() {
		var cx = '006970377737801590391:i8ocqym_g20';
		var gcse = document.createElement('script-tbl');
		gcse.type = 'text/javascript';
		gcse.async = true;
		gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
		var s = document.getElementsByTagName('script-tbl')[0];
		s.parentNode.insertBefore(gcse, s);
	})();
</script>
<gcse:searchbox-only></gcse:searchbox-only>

<style>
	/* Set the line height of the search box text input so it doesn't hide the bottom line of the search box border */
	.gsc-input {
		height: 100% !important;
		line-height: 1.0 !important;
	}
</style>

<!-- END GOOGLE SEARCH BOX -->

        <span class="input-group-btn">
          <a class="btn btn-default search-btn-close">
            <span class="glyphicon glyphicon-remove"></span>
          </a>
        </span>
      </div>
    </div>
    <!-- Close Search Box -->

    <!-- Mobile Mega Nav -->
    <div class="mega-nav hidden">
      <div class="navbar-desktop">
        <!-- Mobile Search -->
        <div class="form-group visible-xs">
			<!-- BEGIN GOOGLE SEARCH BOX -->

<script>
	(function() {
		var cx = '006970377737801590391:i8ocqym_g20';
		var gcse = document.createElement('script-mob');
		gcse.type = 'text/javascript';
		gcse.async = true;
		gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
		var s = document.getElementsByTagName('script-mob')[0];
		s.parentNode.insertBefore(gcse, s);
	})();
</script>
<gcse:searchbox-only></gcse:searchbox-only>

<style>
	/* Set the line height of the search box text input so it doesn't hide the bottom line of the search box border */
	.gsc-input {
		height: 100% !important;
		line-height: 1.0 !important;
	}
</style>

<!-- END GOOGLE SEARCH BOX -->

        </div>
        <!-- Close Mobile Search -->

		<div class="mega-nav-row" style="padding-bottom: 55px;">
	<div class="mega-nav-col hbi-mega-nav-col">
		<h6><a href="/topstories/" class="text-uppercase">News</a></h6>
		<ul>
			<li class="hbi-mobil-menu-item"><a href="/topstories" target="_self">Top Stories</a></li>
			<li class="hbi-mobil-menu-item"><a href="/local" target="_self">Local</a></li>
			<li class="hbi-mobil-menu-item"><a href="/national" target="_self">National</a></li>
			<li class="hbi-mobil-menu-item"><a href="/entertainment" target="_self">Entertainment</a></li>
			<li class="hbi-mobil-menu-item"><a href="/politics" target="_self">Politics</a></li>
			<li class="hbi-mobil-menu-item"><a href="/business" target="_self">Business</a></li>
			<li class="hbi-mobil-menu-item"><a href="/medical" target="_self">Medical</a></li>
			<li class="hbi-mobil-menu-item"><a href="/technology" target="_self">Technology</a></li>
		</ul>
	</div>
	<div class="mega-nav-col hbi-mega-nav-col">
		<h6><a href="/weather/" class="text-uppercase">Weather</a></h6>
		<ul>
			<li class="hbi-mobil-menu-item"><a href="/interactiveradar/?cat=3" target="_self">Interactive Radar</a></li>
			<li class="hbi-mobil-menu-item"><a href="/article/13067/?cat=3" target="_self">Forecast</a></li>
			<li class="hbi-mobil-menu-item"><a href="/schoolalert/" target="_self">School Alert</a></li>
			<li class="hbi-mobil-menu-item"><a href="/pages/weather/weather-images/temps-map-state.shtml/?cat=3" target="_self">Temperatures</a></li>
			<li class="hbi-mobil-menu-item"><a href="/outdoors/?cat=3" target="_self">Outdoors</a></li>
		</ul>
	</div>
	<div class="mega-nav-col hbi-mega-nav-col">
		<h6><a href="/traffic/" class="text-uppercase">Traffic</a></h6>
		<ul>
			<li class="hbi-mobil-menu-item"><a href="/pages/traffic/traffic-map.shtml" target="_self">Traffic Map</a></li>
			<li class="hbi-mobil-menu-item"><a href="/traffic/" target="_self">Top Stories</a></li>
		</ul>
	</div>
	<div class="mega-nav-col hbi-mega-nav-col">
		<h6><a href="/investigative" class="text-uppercase">Investigative</a></h6>
		<ul>
			<li class="hbi-mobil-menu-item"><a href="/article/12420/" target="_self">Top Stories</a></li>
			<li class="hbi-mobil-menu-item"><a href="/in-depth/" target="_self">In-Depth</a></li>
			<li class="hbi-mobil-menu-item"><a href="/pages/misc-pages/send-us-your-news-tip.shtml" target="_self">Send Us Tips</a></li>
		</ul>
	</div>
	<div class="mega-nav-col hbi-mega-nav-col">
		<h6><a href="/sports" class="text-uppercase">Sports</a></h6>
		<ul>
			<li class="hbi-mobil-menu-item"><a href="/article/12688" target="_self">Top Stories</a></li>
			<li class="hbi-mobil-menu-item"><a href="/vikings" target="_self">Vikings</a></li>
			<li class="hbi-mobil-menu-item"><a href="/wild" target="_self">Wild</a></li>
			<li class="hbi-mobil-menu-item"><a href="/twins" target="_self">Twins</a></li>
			<li class="hbi-mobil-menu-item"><a href="/pages/sports/timberwolves-and-lynx.shtml" target="_self">Timberwolves / Lynx</a></li>
			<li class="hbi-mobil-menu-item"><a href="/article/13150/" target="_self">Minnesota United</a></li>
			<li class="hbi-mobil-menu-item"><a href="/collegesports" target="_self">College Sports</a></li>
			<li class="hbi-mobil-menu-item"><a href="/highschoolsports" target="_self">High School Sports</a></li>
		</ul>
	</div>
	<div class="mega-nav-col hbi-mega-nav-col">
		<h6><a href="/5takeaction" class="text-uppercase">5 Take Action</a></h6>
	</div>
	<div class="mega-nav-col hbi-mega-nav-col">
		<h6><a href="/digitalextras" class="text-uppercase">Digital Extras</a></h6>
		<ul>
			<li class="hbi-mobil-menu-item"><a href="/livevideo" target="_self">Live Video</a></li>
			<li class="hbi-mobil-menu-item"><a href="/video" target="_self">On-Demand Video</a></li>
			<li class="hbi-mobil-menu-item"><a href="/photogalleries" target="_self">Photo Galleries</a></li>
			<li class="hbi-mobil-menu-item"><a href="/alertsandapps" target="_self">Alerts & App</a></li>
			<li class="hbi-mobil-menu-item"><a href="/links/" target="_blank">As Seen on 5 Eyewitness News</a></li>
		</ul>
	</div>
	<div class="mega-nav-col hbi-mega-nav-col">
		<h6><a href="/article/21/" class="text-uppercase">KSTP TV</a></h6>
		<ul>
			<li class="hbi-mobil-menu-item"><a href="/tvschedule" target="_self">Programming</a></li>
			<li class="hbi-mobil-menu-item"><a href="http://abc.go.com/?aff=kstp" target="_blank">ABC Programming</a></li>
			<li class="hbi-mobil-menu-item"><a href="/atissue" target="_self">At Issue</a></li>
			<li class="hbi-mobil-menu-item"><a href="http://twincitieslive.com/" target="_blank">Twin Cities Live</a></li>
			<li class="hbi-mobil-menu-item"><a href="http://kstc45.com/" target="_blank">45TV</a></li>
		</ul>
	</div>
	<div class="mega-nav-col hbi-mega-nav-col">
		<h6><a href="/links/" class="text-uppercase">Links</a></h6>
		<ul>
			<li class="hbi-mobil-menu-item"><a href="/article/24/" target="_self">Outreach and Events</a></li>
			<li class="hbi-mobil-menu-item"><a href="/contests/" target="_self">Contests</a></li>
			<li class="hbi-mobil-menu-item"><a href="http://twincitieslive.com/article/12491/" target="_blank">What's Happening This Weekend?</a></li>
		</ul>
	</div>
	<div class="mega-nav-col hbi-mega-nav-col">
		<h6><a href="/pages/misc-pages/contact-5-eyewitness-news.shtml" class="text-uppercase">Contact Us</a></h6>
		<ul>
			<li class="hbi-mobil-menu-item"><a href="/newsteam">News Team</a></li>
			<li class="hbi-mobil-menu-item"><a href="/pages/misc-pages/send-us-your-news-tip.shtml">Submit a News Tip</a></li>
			<li class="hbi-mobil-menu-item"><a href="/pages/misc-pages/contact-5-eyewitness-news.shtml">Submit a Question</a></li>
			<li class="hbi-mobil-menu-item"><a href="/pages/misc-pages/hubbard-broadcasting-stations.shtml">HBI Properties</a></li>
			<li class="hbi-mobil-menu-item"><a href="https://hubbardbroadcasting.com/">Careers</a></li>
			<li class="hbi-mobil-menu-item"><a href="/pages/misc-pages/send-us-your-advertising-request-or-question.shtml/">Advertise with Us</a></li>
		</ul>
	</div>
</div>


      </div>
    </div>
    <!-- Close Mobile Mega Nav -->
  </nav>
<!-- End: NAV-MOBI -->
<!-- Start: WSI-SCRIPT-CALL -->
<script>buildWeatherWidget();</script>
<!-- End: WSI-SCRIPT-CALL -->

    <!-- LRT -->


</header>
<!-- Close Main Navigation -->
<!-- Main Container -->
<div class="container">
	<!-- Begin alert row -->
    <!-- Load Alerts -->

	<div class="row">
	<div class="col-xs-12" class="hbi-weather-alert">
		<div id="severeWeatherAlert-1" class="alert alert-danger alert-dismissible hbi-weather-alert">		<button type="button" class="close" data-dismiss="alert"><span class=" hbi-weather-alert-close">&times;</span></button>			<a href="/article/13081/" class="hbi-weather-alert-link"> Dense Fog Advisory - Minnesota: Carver, Dakota, Hennepin, Scott, Wright and 11 other counties</a>		</div >
	</div>
</div>
<!-- last update: 03/14/2019 12:15:08 AM -->
<!-- no scheduled live video -->
<!-- 03/14/2019 12:16:00 AM -->

<!-- updated 3/14/2019 12:10:00 AM -->

 
    
<!-- End Load Alerts -->
    
	<!-- Endalert row -->	
	<!-- Begin Header Section Row -->	
    <div class="row">  
    
    
        <div id="ADSPACE01" class="ad-top-wrapper"><script>googletag.cmd.push(function() {googletag.display('ADSPACE01');});</script><div class='hbi-ad-advertiser'>Advertisement</div></div>
    
    </div>  
	<!-- End Header Section Row -->	
    <!-- Main Content and Sidebar Section -->
    <div class="row">
        <!-- Main Content Column-->
        <div class="col col-offset-right-300">
            <!-- White Panel -->
            <div class="panel panel-default">
                <!-- Begin First Row -->
                <div class="row hbi-row-padding">
                     



<!-- Start: Story Page --> 


<div class="col"> <!-- Main Element Column --> 
	<div class="row">
		<div class="col-md-10 col-md-offset-1">
			<div class="panel-body hbi-story-panel-body-before-ad">
				<h1 class="hbi-h1">Giants trade Beckham to Browns, Jets get Bell</h1>
				<div class="row story-body">
					<div class="col ">
						
                                <p><img class="img-responsive" src="https://kstp.com/APImages/APca600d68e42e4fde8346f713ec2e0d3a.jpg" alt="Blake Bortles, Terrell Suggs, C.J. Mosley">
    							     
								
                                    <span class="hbi-story-media-credit">Photo: AP</span>
                                
                                    <br /><span class="hbi-story-media-caption">Blake Bortles, Terrell Suggs, C.J. Mosley</span>
                                </p>
							
					</div>
				</div>
				
				<div class="row story-body hbi-story-body">
					<div class="col-xs-12">
					<p><em>March 13, 2019 12:21 AM</em></p> <p>While the free agency spending frenzy runs wild, the Giants and Browns found a way to overshadow it Tuesday night: a trade of Odell Beckham Jr.</p>              <p>Not to be outdone, however, the Jets got the guy at the top of their free agency list, agreeing with former Steelers running back Le'Veon Bell on a deal early Wednesday morning.</p>  
					</div>
				</div>
			</div>
		</div> 
	 </div>  

		 
	<div class="row visible-xs visible-sm">
		<div class="col" style="margin-bottom:10px;">
				
        <div id="ADSPACE02" class=""><script>googletag.cmd.push(function() {googletag.display('ADSPACE02');});</script><div class='hbi-ad-advertiser'>Advertisement</div></div>
           
		</div>
	</div>

	<div class="row">
		<div class="col-md-10 col-md-offset-1">
			<div class="panel-body hbi-story-panel-body-after-ad">
   				<div class="row story-body hbi-story-body">
					<div class="col-xs-12">
	                                 <p>The Giants are sending their star receiver to Cleveland for first- and second-round draft picks in April and safety Jabrill Peppers in the second blockbuster trade in four days. On Saturday, Pittsburgh sent unhappy wideout Antonio Brown to Oakland, a deal Brown forced.</p>              <p>Beckham is the NFL's highest-paid receiver; he got a five-year, $90 million extension last August. He comes off two injury-plagued seasons, but when healthy is a game-breaking target, just like Brown.</p>              <p>The two trades become official Wednesday when the league's business year begins. People with knowledge of the moves told The Associated Press of the trades, speaking anonymously because the transactions can't be announced until after 4 p.m. EDT on Wednesday.</p>              <p>Beckham is known for his gravity-defying catches and breakaway skills, but also for being temperamental. He was suspended for one game in 2015 for his on-field battles with cornerback Josh Norman, then with Carolina.</p>              <p>Cleveland suddenly looks like a force in an AFC North in which both Baltimore and Pittsburgh have been weakened in the offseason. With Beckham reunited with receiver Jarvis Landry, a teammate at LSU, it gives quarterback Baker Mayfield two top targets. The Browns, who went 7-8-1 last season after not winning a game in 2017, haven't made the playoffs since 2002.</p>              <p>The mega-trade came hours after another busy day of dealmaking.</p>              <p>The money flowed out of New Jersey, with the Jets agreeing Tuesday to contracts with three players: wide receivers Jamison Crowder and Josh Bellamy, and linebacker C.J. Mosley. The team also will re-sign cornerback Darryl Roberts and defensive end Henry Anderson.</p>              <p>But the big news came when the Jets and Bell agreed on a deal. ESPN first reported the signing, saying the contract is for four years and $52.5 million.</p>              <p>The deal gives new coach Adam Gase and second-year quarterback Sam Darnold a big-time playmaker, arguably the best player at his position before Bell opted to sit out all of last season rather than sign a franchise tender with Pittsburgh.</p>              <p>Bell has rushed for 5,336 yards and 35 touchdowns, and has 312 catches for 2,660 yards and seven scores as one of the most versatile and dangerous offensive players in the NFL.</p>              <p>"I'm back in the green baby," the former Michigan State star wrote on Twitter. "Let's get it."</p>              <p>It streamed out of Green Bay, with the Packers getting deals with edge rusher Za'Darius Smith, linebacker Preston Smith, safety Adrian Amos and offensive lineman Billy Turner. The Packers also cut veteran linebacker Nick Perry.</p>              <p>And it poured out of Oakland once more when the Raiders kept their vault open and agreed to a four-year contract with safety Lamarcus Joyner . The Raiders previously made big moves on offense by trading for Brown and agreeing to a deal with tackle Trent Brown.</p>              <p>Given the "legal tampering" freedom the league now allows for two days, well, let Ravens general manager Eric DeCosta describe the mayhem.</p>              <p>"Unfortunately for us, the market is irrational at times and we can't be held responsible for what other teams want to pay," DeCosta said. "All we can do is try to negotiate in good faith with agents and the players."</p>              <p>JETS</p>              <p>The Jets had more than $82.5 million to spend in free agency, and they are spending it. They thought they also had an agreement with Vikings linebacker Anthony Barr, but he opted instead to return to Minnesota.</p>              <p>Not that the Jets fell short in adding talent. The 26-year-old Mosley is a four-time Pro Bowl linebacker who will get a reported five years and $85 million, including a whopping $51 million guaranteed. Mosley has had at least 100 tackles in every season but 2016, when he missed two games with an injury and finished with 92. He will be a centerpiece of new defensive coordinator Gregg Williams' unit.</p>              <p>In dire need of receivers for Darnold, New York is adding the 26-year-old Crowder as a playmaking slot receiver. Crowder, whose deal reportedly is for three years and $28.5 million, had 221 catches for 2,628 yards and 14 touchdowns in four seasons with Washington. He was limited to nine games last season because of an ankle injury.</p>              <p>Bellamy has 76 career catches for 999 yards and five touchdowns, and is also a special teams contributor. He spent the last five years with Chicago.</p>              <p>PACKERS</p>              <p>The defensive signings should improve a unit that ranked 18th in the NFL in 2018. Za'Darius Smith is getting the biggest deal: $66 million over four years with $34.5 million in the first two years, according to his agency, SportsTrust Advisors. The 28-year-old Smith led the Ravens with 8½ sacks last season — including three in one game against Tennessee — and has 18½ in his 58-game career.</p>              <p>Preston Smith agreed to a $52 million, four-year contract with $16 million guaranteed. For Amos, it is a $37 million, four-year contract. Amos, 25, started all 16 games for the NFC North rival Chicago Bears last season and had two interceptions.</p>              <p>Turner gets a $28 million, four-year contract.</p>              <p>RAIDERS</p>              <p>Joyner becomes the first major addition on defense in Oakland. He played last season on a franchise tag for the Rams, earning $11.3 million. But Los Angeles signed Eric Weddle last week to be Joyner's replacement.</p>              <p>The 28-year-old Joyner was originally a second-round pick by the Rams in 2014 and played 67 games over five seasons with the franchise. He has four interceptions and 25 passes defensed in his career.</p>              <p>RAVENS</p>              <p>It's been a difficult two days for the Ravens. Za'Darius Smith, Mosley, Weddle and long-time star Terrell Suggs (Cardinals) all departed from their top-ranked defense.</p>              <p>"We see good young players leave us every year," DeCosta said. "We've tried to adjust over time, but I think now is a great opportunity for us to become financially responsible, to get control over the salary cap to understand the concept of right player, right price."</p>              <p>___</p>              <p>More AP NFL: https://apnews.com/tag/NFL and https://twitter.com/AP_NFL</p>     
					</div> 
				</div> 
			</div> 
		</div>
	</div>
	
	<div class="panel-body">
		<div class="row"> 
     <h4 class="hbi-5">Connect with KSTP</h4>
<div style="font-size:120%">
<a href="https://kstp.com/pages/misc-pages/mobile-apps.shtml"/>Download the KSTP News app on your mobile device</a>
<br />
    <a href= "https://www.facebook.com/KSTPTV/">KSTP Facebook</a>
<br />
      <a href="https://www.instagram.com/kstptv"/>KSTP Instagram</a>
<br />
      <a href= "https://twitter.com/KSTP">KSTP Twitter</a>
 </div>
<br />
 <div style="display:flex;flex-direction:row;">
      <a href= "https://www.facebook.com/KSTPTV/" target="_self">
      <img class="img-responsive" src="/kstpImages/_misc_graphics/KSTPFacebook2.jpg" alt=""></a>
      <a href= "https://www.instagram.com/kstptv/" target="_self">
      <img class="img-responsive" src="/kstpImages/_misc_graphics/KSTPInstagram2.jpg" alt=""></a>
      <a href= "https://twitter.com/KSTP/" target="_self">
      <img class="img-responsive" src="/kstpImages/_misc_graphics/KSTPTwitter2.jpg" alt=""></a>

<br />
</div>
   
<h4 class="hbi-5">Join the conversation on our social media platforms. Share your comments on our Facebook, Instagram, and Twitter pages.</h4>



</div> 
		<div class="row story-body hbi-story-body">
			<div class="col-md-4 col-md-offset-1">
			
				<h3 class="hbi-story-credits-h3">Credits</h3>
				<p class="hbi-story-credits-p">
					<span style="padding-left:10px;">By BARRY WILNER</span>
				</p>
			
			   <p class="hbi-story-dates-p">
			   
				<em>Updated: March 13, 2019 12:21 AM</em><br />
			   
				<em>Created: March 13, 2019 12:10 AM</em>
			   
			   </p>
			
				<p class="hbi-story-copy-p">(Copyright 2019 by The Associated Press. All Rights Reserved.)</p>
			
			</div>
			
        <div id="ADSPACE03" class="col-md-6"><script>googletag.cmd.push(function() {googletag.display('ADSPACE03');});</script><div class='hbi-ad-advertiser'>Advertisement</div></div>
           
		</div>
	</div>

</div>  <!-- End: Main Element Column --> 


<!-- End: Story Page -->

                          </div> <!-- End on Row -->
                          
                          <div class="row hbi-row-padding"> <!-- Begin Row -->
                          
<!-- Start: 2016-E-MC-08 -->
<div class="col" id="Xref1821">
 <div class="panel panel-default">
  
    <div class="row">
        <div class="col-xs-12">
       		
   	            
                <!-- Dynamic Content Block -->
                
      <!-- Widget - MC - Top Stories (6) - E-MC-04A -->
       
<!-- Start: 2016-E-MC-04A -->
<!-- Category Header Row-->
<div class="" id="Xref0">
	
		<div class="row"><div class="col-xs-12"><div class="panel-heading">
            <h3 class="panel-title text-uppercase text-muted">
							
					<a href="/article/127/">Top Stories <span class="glyphicon glyphicon-menu-right"></span></a>
				
            </h3>
		</div></div></div>    
    	

	<div class="row ">
		
            <div class="col-md-4">
                
                	<div class="embed-responsive embed-responsive-16by9">
                    	<a href="/news/non-profit-provides-legal-aid-to-kids-in-child-protective-services/5278402/?cat=1" target="_self">
                        	<img class="img-responsive" src="/kstpImages/repository/2019-03/800ChildrensLawKSTP.jpg" alt="Non-profit provides legal aid to kids in child protective services"/>
                        </a>
                   	</div>
					
    		                        
                
                <div class="panel-body padding-top-none">
                	<h4 class="hbi-h4">
                    	<a href="/news/non-profit-provides-legal-aid-to-kids-in-child-protective-services/5278402/?cat=1" target="_self"><span class="icon play-video"></span>Non-profit provides legal aid to kids in child protective services
</a>
                    </h4>    
					
                    <div id="hbi-short-date-0-5278402" class="hbi-story-time"></div>
                    <script>execCheckDiffShort("03/13/2019 10:36 PM","minutes",0,5278402);</script>
                    
                </div>
            </div>
           	
            <div class="col-md-4">
                
                	<div class="embed-responsive embed-responsive-16by9">
                    	<a href="/news/amber-alert-suspect-in-custody-girl-may-be-in-minnesota-or-michigan-wdio/5278410/?cat=1" target="_self">
                        	<img class="img-responsive" src="/kstpImages/repository/2019-03/800AmberAlertBabyWISN.jpg" alt="Amber Alert: Suspect in custody, girl may be in Minnesota or Michigan"/>
                        </a>
                   	</div>
					
    		                        
                
                <div class="panel-body padding-top-none">
                	<h4 class="hbi-h4">
                    	<a href="/news/amber-alert-suspect-in-custody-girl-may-be-in-minnesota-or-michigan-wdio/5278410/?cat=1" target="_self">Amber Alert: Suspect in custody, girl may be in Minnesota or Michigan
</a>
                    </h4>    
					
                    <div id="hbi-short-date-0-5278410" class="hbi-story-time"></div>
                    <script>execCheckDiffShort("03/13/2019 10:27 PM","minutes",0,5278410);</script>
                    
                </div>
            </div>
           	
            <div class="col-md-4">
                
                	<div class="embed-responsive embed-responsive-16by9">
                    	<a href="/news/rain-on-top-of-snow-makes-for-messy-commute-in-the-twin-cities/5278334/?cat=1" target="_self">
                        	<img class="img-responsive" src="/kstpImages/repository/2019-03/800IceKSTP.jpg" alt="Rain on top of snow makes for messy commute in the Twin Cities"/>
                        </a>
                   	</div>
					
    		                        
                
                <div class="panel-body padding-top-none">
                	<h4 class="hbi-h4">
                    	<a href="/news/rain-on-top-of-snow-makes-for-messy-commute-in-the-twin-cities/5278334/?cat=1" target="_self"><span class="icon play-video"></span>Rain on top of snow makes for messy commute in the Twin Cities
</a>
                    </h4>    
					
                    <div id="hbi-short-date-0-5278334" class="hbi-story-time"></div>
                    <script>execCheckDiffShort("03/13/2019 10:15 PM","minutes",0,5278334);</script>
                    
                </div>
            </div>
           	</div><!-- Soft Row Break --><div class="row">
            <div class="col-md-4">
                
                	<div class="embed-responsive embed-responsive-16by9">
                    	<a href="/weather/more-rain-to-soak-up-thursday-turning-to-snow-in-evening-hours/5278362/?cat=1" target="_self">
                        	<img class="img-responsive" src="/kstpImages/repository/2019-03/800RainRoadWetConditions-MGNImagesPixabay.jpg" alt="More rain to soak up Thursday, rain to snow mix late"/>
                        </a>
                   	</div>
					
    		                        
                
                <div class="panel-body padding-top-none">
                	<h4 class="hbi-h4">
                    	<a href="/weather/more-rain-to-soak-up-thursday-turning-to-snow-in-evening-hours/5278362/?cat=1" target="_self"><span class="icon play-video"></span>More rain to soak up Thursday, rain to snow mix late
</a>
                    </h4>    
					
                    <div id="hbi-short-date-0-5278362" class="hbi-story-time"></div>
                    <script>execCheckDiffShort("03/13/2019 10:48 PM","minutes",0,5278362);</script>
                    
                </div>
            </div>
           	
            <div class="col-md-4">
                
                	<div class="embed-responsive embed-responsive-16by9">
                    	<a href="/news/minnesota-fraud-investigators-testify-allege-108m-in-taxpayer-financed-child-daycare-fraud/5278338/?cat=1" target="_self">
                        	<img class="img-responsive" src="/kstpImages/repository/2019-03/800MeetingKSTP.jpg" alt="Minnesota fraud investigators testify, allege $108M in taxpayer-financed child daycare fraud"/>
                        </a>
                   	</div>
					
    		                        
                
                <div class="panel-body padding-top-none">
                	<h4 class="hbi-h4">
                    	<a href="/news/minnesota-fraud-investigators-testify-allege-108m-in-taxpayer-financed-child-daycare-fraud/5278338/?cat=1" target="_self"><span class="icon play-video"></span>Minnesota fraud investigators testify, allege $108M in taxpayer-financed child daycare fraud
</a>
                    </h4>    
					
                    <div id="hbi-short-date-0-5278338" class="hbi-story-time"></div>
                    <script>execCheckDiffShort("03/13/2019 10:18 PM","minutes",0,5278338);</script>
                    
                </div>
            </div>
           	
            <div class="col-md-4">
                
                	<div class="embed-responsive embed-responsive-16by9">
                    	<a href="/news/construction-crews-on-new-red-wing-bridge-work-around-the-clock-to-beat-flooding/5278113/?cat=1" target="_self">
                        	<img class="img-responsive" src="/kstpImages/repository/2019-03/800RedWingBridgeKSTP.jpg" alt="Construction crews on new Red Wing bridge work around the clock to beat flooding"/>
                        </a>
                   	</div>
					
    		                        
                
                <div class="panel-body padding-top-none">
                	<h4 class="hbi-h4">
                    	<a href="/news/construction-crews-on-new-red-wing-bridge-work-around-the-clock-to-beat-flooding/5278113/?cat=1" target="_self"><span class="icon play-video"></span>Construction crews on new Red Wing bridge work around the clock to beat flooding
</a>
                    </h4>    
					
                    <div id="hbi-short-date-0-5278113" class="hbi-story-time"></div>
                    <script>execCheckDiffShort("03/13/2019 05:42 PM","minutes",0,5278113);</script>
                    
                </div>
            </div>
           	
	</div>
</div>
<!-- End: 2016-E-MC-04A -->


                <!-- End Dynamic Content Block --> 
                
	           
               
            
        </div>
    </div>

</div>
</div>
<!-- End: 2016-E-MC-08 -->

                </div>
                <!-- End Last Row -->  
            </div> 
            <!-- Close White Panel -->
        </div>
 		 	    
        <!-- End Main Content Column --> 
        <!-- SideBar Column -->    
        <div class="col col-fixed-300 visible-lg visible-md"> 
			
            <!-- Begin Header Section Row -->
                
<!-- Start: E-SB-2 -->
	<div class="panel panel-default">
	        
       	            <!-- Dynamic Content Block -->

      <!-- Widget - SB - Just Posted (3) - Homepage Story page - E-SB-38CO -->
      
<!-- Start: 2016-E-SB-38CO -->

<div class="panel panel-default">
       <div class="row"><div class="col-xs-12"><div class="panel-heading">
            <h3 class="panel-title text-uppercase text-muted">What's Trending</h3>
        </div></div></div>
        <div class="panel-body" style="height:250px;overflow-y: auto;">
		
            <div class="row">
    		  <div class="col-xs-3 hbi-story-time">03/13/2019<br />11:51 PM</div>              
              <div class="col-xs-9 margin-top-none">
	              <h6 class="media-heading hbi-h6">
            	  	<a href="/national/countries-and-carriers-around-globe-ground-boeing-737-max/5277084/?cat=140" target="">
				  	Countries and carriers around globe ground Boeing 737 Max
    	            </a>
	                </h6>
              </div>
            </div> 
            <hr />
            <div class="row">
    		  <div class="col-xs-3 hbi-story-time">03/13/2019<br />11:51 PM</div>              
              <div class="col-xs-9 margin-top-none">
	              <h6 class="media-heading hbi-h6">
            	  	<a href="/national/arkansas-lawmakers-send-governor-18-week-abortion-ban/5277902/?cat=162" target="">
				  	Arkansas, Utah lawmakers pass 18-week abortion bans
    	            </a>
	                </h6>
              </div>
            </div> 
            <hr />
            <div class="row">
    		  <div class="col-xs-3 hbi-story-time">03/13/2019<br />11:22 PM</div>              
              <div class="col-xs-9 margin-top-none">
	              <h6 class="media-heading hbi-h6">
            	  	<a href="/business/boeings-newest-plane-becomes-its-biggest-headache/5278423/?cat=140" target="">
				  	Boeing's newest plane becomes its biggest headache
    	            </a>
	                </h6>
              </div>
            </div> 
            <hr />
            <div class="row">
    		  <div class="col-xs-3 hbi-story-time">03/13/2019<br />11:22 PM</div>              
              <div class="col-xs-9 margin-top-none">
	              <h6 class="media-heading hbi-h6">
            	  	<a href="/national/tennessee-lawmakers-advance-transgender-bathroom-bill/5278291/?cat=162" target="">
				  	Tennessee lawmakers advance transgender 'bathroom bill'
    	            </a>
	                </h6>
              </div>
            </div> 
            <hr />
            <div class="row">
    		  <div class="col-xs-3 hbi-story-time">03/13/2019<br />11:22 PM</div>              
              <div class="col-xs-9 margin-top-none">
	              <h6 class="media-heading hbi-h6">
            	  	<a href="/national/new-york-inaugurates-its-25-billion-mini-city-hudson-yards/5278346/?cat=162" target="">
				  	New York inaugurates its $25 billion mini-city, Hudson Yards
    	            </a>
	                </h6>
              </div>
            </div> 
            <hr />
            <div class="row">
    		  <div class="col-xs-3 hbi-story-time">03/13/2019<br />10:51 PM</div>              
              <div class="col-xs-9 margin-top-none">
	              <h6 class="media-heading hbi-h6">
            	  	<a href="/business/us-stocks-move-higher-led-by-technology-and-health-care/5277398/?cat=140" target="">
				  	Asian stocks edge up on stimulus hopes after Chinese data
    	            </a>
	                </h6>
              </div>
            </div> 
            <hr />
            <div class="row">
    		  <div class="col-xs-3 hbi-story-time">03/12/2019<br />10:21 AM</div>              
              <div class="col-xs-9 margin-top-none">
	              <h6 class="media-heading hbi-h6">
            	  	<a href="/national/woman-picks-matching-numbers-30-times-to-win-lottery-game/5275997/?cat=144" target="">
				  	Woman picks matching numbers 30 times to win lottery game
    	            </a>
	                </h6>
              </div>
            </div> 
            <hr />
            <div class="row">
    		  <div class="col-xs-3 hbi-story-time">03/08/2019<br />02:51 PM</div>              
              <div class="col-xs-9 margin-top-none">
	              <h6 class="media-heading hbi-h6">
            	  	<a href="/national/police-puppy-stabbed-during-house-break-in/5272044/?cat=144" target="">
				  	Police: Puppy stabbed during break-in 'getting lots of love'
    	            </a>
	                </h6>
              </div>
            </div> 
            <hr />
            <div class="row">
    		  <div class="col-xs-3 hbi-story-time">03/08/2019<br />09:51 AM</div>              
              <div class="col-xs-9 margin-top-none">
	              <h6 class="media-heading hbi-h6">
            	  	<a href="/national/surrogate-bonds-with-baby-gorilla-rejected-by-mother/5272045/?cat=144" target="">
				  	Surrogate bonds with baby gorilla rejected by mother
    	            </a>
	                </h6>
              </div>
            </div> 
            	      
        </div>
</div>     
<!-- End: 2016-E-SB-38CO -->


<!-- End Dynamic Content Block --> 

	                
                    
                
    </div>
<!-- End: E-SB-2 -->

            <!-- Begin Header Section Row -->
                
        <div id="ADSPACE04" class=""><script>googletag.cmd.push(function() {googletag.display('ADSPACE04');});</script><div class='hbi-ad-advertiser'>Advertisement</div></div>
    
            <!-- Begin Header Section Row -->
                
<!-- Start: E-SB-2 -->
	<div class="panel panel-default">
	        
       	            <!-- Content Block 24 144 -->
<div class="panel panel-default">
	<div class="panel-heading">
		<h3 class="panel-title text-uppercase text-muted">Most Read Stories</h3>
	</div>
	<div class="media">
		<div class="media-body">
			<h6 class="media-heading hbi-h6">
				<a href="/news/wisconsin-man-arrested-after-throwing-puppies-in-garbage-can/5278116/">Wisconsin man arrested after throwing puppies in garbage can</a>
			</h6>
		</div>
		<div class="media-right">
			<a href="/news/wisconsin-man-arrested-after-throwing-puppies-in-garbage-can/5278116/">
			<img class="media-object" src="/kstpImages/repositoryThumbs/2019-03/garbage-pups3.jpg" alt="Wisconsin man arrested after throwing puppies in garbage can" width="120" height="68">
			</a>
		</div>
	</div>
	<hr class="margin-top-bottom-sm">
	<div class="media">
		<div class="media-body">
			<h6 class="media-heading hbi-h6">
				<a href="/news/minnesota-fraud-investigators-testify-allege-108m-in-taxpayer-financed-child-daycare-fraud/5278338/">Minnesota fraud investigators testify, allege $108M in taxpayer-financed child daycare fraud</a>
			</h6>
		</div>
		<div class="media-right">
			<a href="/news/minnesota-fraud-investigators-testify-allege-108m-in-taxpayer-financed-child-daycare-fraud/5278338/">
			<img class="media-object" src="/kstpImages/repositoryThumbs/2019-03/800MeetingKSTP.jpg" alt="Minnesota fraud investigators testify, allege $108M in taxpayer-financed child daycare fraud" width="120" height="68">
			</a>
		</div>
	</div>
	<hr class="margin-top-bottom-sm">
	<div class="media">
		<div class="media-body">
			<h6 class="media-heading hbi-h6">
				<a href="/news/woodbury-school-accused-of-diabetes-related-discrimination/5276522/">Woodbury school accused of diabetes-related discrimination</a>
			</h6>
		</div>
		<div class="media-right">
			<a href="/news/woodbury-school-accused-of-diabetes-related-discrimination/5276522/">
			<img class="media-object" src="/kstpImages/repositoryThumbs/2019-03/800NewLifeAcademyGirl.jpg" alt="Woodbury school accused of diabetes-related discrimination" width="120" height="68">
			</a>
		</div>
	</div>
	<hr class="margin-top-bottom-sm">
	<div class="media">
		<div class="media-body">
			<h6 class="media-heading hbi-h6">
				<a href="/news/trump-us-ground-boeing-737-max-8-9-after-ethiopia-crash/5277835/">Trump: US grounding Boeing 737 Max 8, 9 after Ethiopia crash</a>
			</h6>
		</div>
		<div class="media-right">
			<a href="/news/trump-us-ground-boeing-737-max-8-9-after-ethiopia-crash/5277835/">
			<img class="media-object" src="/kstpImages/repositoryThumbs/2019-03/boeing-737-max-8-mgn.jpg" alt="Trump: US grounding Boeing 737 Max 8, 9 after Ethiopia crash" width="120" height="68">
			</a>
		</div>
	</div>
	<hr class="margin-top-bottom-sm">
	<div class="media">
		<div class="media-body">
			<h6 class="media-heading hbi-h6">
				<a href="/news/st-paul-marina-prepares-for-likely-flooding/5276627/">St. Paul marina prepares for likely flooding</a>
			</h6>
		</div>
		<div class="media-right">
			<a href="/news/st-paul-marina-prepares-for-likely-flooding/5276627/">
			<img class="media-object" src="/kstpImages/repositoryThumbs/2019-03/marina-web.jpg" alt="St. Paul marina prepares for likely flooding" width="120" height="68">
			</a>
		</div>
	</div>
</div>
<!-- End Content Block 24 144 --> 
	                
                    
                
    </div>
<!-- End: E-SB-2 -->

            <!-- Begin Header Section Row -->
                
<!-- Start: E-SB-2 -->
	<div class="panel panel-default">
	        
       	            <iframe src="https://www.facebook.com/plugins/page.php?href=https%3A%2F%2Fwww.facebook.com%2FKSTPTV%2F&tabs=timeline&width=340&height=500&small_header=false&adapt_container_width=true&hide_cover=false&show_facepile=true&appId" width="340" height="500" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true" allow="encrypted-media"></iframe>
	                
                    
                
    </div>
<!-- End: E-SB-2 -->

            <!-- Begin Header Section Row -->
                
<!-- Start: E-SB-2 -->
	<div class="panel panel-default">
	        
       	                            <!-- Dynamic Content Block -->
                
    	<!-- Widget - SB - Photo Gallery (2) - E-SB-27.2016-E-SB-27 -->
	

                <!-- End Dynamic Content Block --> 
                
	                
                    
                
    </div>
<!-- End: E-SB-2 -->

        </div> 
        <!-- Close SideBar Column -->
    </div>
    <!-- Main Content and Sidebar Section -->
	<!-- Begin Footer Section Row -->	
    <div class="row">  
    
        <div id="ADSPACE06" class="ad-top-wrapper"><script>googletag.cmd.push(function() {googletag.display('ADSPACE06');});</script><div class='hbi-ad-advertiser'>Advertisement</div></div>
    
    </div>
	<!-- End Footer Section Row -->	
</div>
<!-- Close Main Container -->

<footer id="footer">
		
		<div class="container">
<!-- Start: FOOTER -->
	<!-- Start Footer Link Section -->
	<div class="row">
	<div class="col-md-2 visible-md visible-lg">
		<ul class="list-unstyled list-lg-space">
			<li><a href="/topstories/">NEWS</a></li>
		</ul>
	</div>
	<div class="col-md-2 visible-md visible-lg">
		<ul class="list-unstyled list-lg-space">
			<li><a href="/weather/">WEATHER</a></li>
		</ul>
	</div>
	<div class="col-md-2 visible-md visible-lg">
		<ul class="list-unstyled list-lg-space">
			<li><a href="/traffic/">TRAFFIC</a></li>
		</ul>
	</div>
	<div class="col-md-2 visible-md visible-lg">
		<ul class="list-unstyled list-lg-space">
			<li><a href="/sports/">SPORTS</a></li>
		</ul>
	</div>
	<div class="col-md-2">
		<a href="/"><img alt="KSTP.com 5 Eyewitness News" class="img-responsive" src="/assets/images/weblogos.png" /></a>
	</div>
</div>
<div class="row">
	<div class="col-md-2 visible-md visible-lg">
		<ul class="list-unstyled list-lg-space">
			<li><a href="/video/">VIDEO</a></li>
		</ul>
	</div>
	<div class="col-md-2 visible-md visible-lg">
		<ul class="list-unstyled list-lg-space">
			<li><a href="/article/12157/">DIGITAL EXTRAS</a></li>
		</ul>
	</div>
	<div class="col-md-2 visible-md visible-lg">
		<ul class="list-unstyled list-lg-space">
			<li><a href="http://www.kstc45.com" target="_blank">45TV</a></li>
		</ul>
	</div>
	<div class="col-md-2 visible-md visible-lg">
		<ul class="list-unstyled list-lg-space">
			<li><a href="/pages/misc-pages/contact-5-eyewitness-news.shtml">CONTACT US</a></li>
		</ul>
	</div>
	<div class="col-md-4">
		<br />
			<a href="https://www.facebook.com/KSTPTV/" target="_blank"><img src="/2016/icons/facebook_32x32.jpg" width="28" height="28" vspace="2" border="0" alt="Like Us on Facebook"></a>
			<a href="https://twitter.com/kstp" target="_blank"><img src="/2016/icons/twitter_32x32.jpg" width="28" height="28" vspace="2" border="0" alt="Follow Us on Twitter"></a>
			<a href="https://www.instagram.com/kstptv/" target="_blank"><img src="/2016/icons/instagram_32x32.jpg" width="28" height="28" vspace="2" border="0" alt="Follow Us on Instagram"></a>
			<a href="https://itunes.apple.com/us/app/kstp-mpls-st-paul/id546024067?mt=8"><img src="/2016/icons/apple_32x32.jpg" width="28" height="28" vspace="2" border="0" alt="iOS App"></a>
			<a href="https://play.google.com/store/apps/details?id=com.doapps.android.mln.MLN_fe2672296a661b7acdf9fe36f27e7a55&hl=en"><img src="/2016/icons/android_32x32.jpg" width="28" height="28" vspace="2" border="0" alt="Android App"></a>
<!-- <div class="addthis_horizontal_follow_toolbox"></div> -->
		<!-- <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5757269bf8dc7415"></script> -->
	</div>
</div>
<div class="row">
	<div class="col-md-2 visible-md visible-lg">
		<ul class="list-unstyled list-lg-space">
			<li><a href="http://www.metv.com/" target="_blank">MeTV-Twin Cities</a></li>
		</ul>
	</div>
	<div class="col-md-2 visible-md visible-lg">
		<ul class="list-unstyled list-lg-space">
			<li><a href="http://twincities.thistv.com/" target="_blank">this-Twin Cities</a></li>
		</ul>
	</div>
	<div class="col-md-2 visible-md visible-lg">
		<ul class="list-unstyled list-lg-space">
			<li><a href="https://www.prep45.com/" target="_blank">prep45.com</a></li>
		</ul>
	</div>
	<div class="col-md-2 visible-md visible-lg">
		<ul class="list-unstyled list-lg-space">
			<li><a href="http://antennatv.tv/"  target="_blank">Antenna TV</a></li>
		</ul>
	</div>
</div>
	<!-- End Footer Link Section -->
    <hr>
	<!-- Start FCC Section -->
    <div class="row">
<div class="col-xs-12 text-center">
<p><b>
<a href="https://publicfiles.fcc.gov/tv-profile/kstp-tv" target="_blank">KSTP-TV FCC Public Inspection File</a>
 | 
<a href="https://publicfiles.fcc.gov/tv-profile/ksax" target="_blank">KSAX-TV FCC Public Inspection File</a>
 | 
<a href="https://publicfiles.fcc.gov/tv-profile/krwf" target="_blank">KRWF-TV FCC Public Inspection File</a>
 | 
<a href="/article/stories/s2937908.shtml" target="_blank">Additional Public Information</a>
</b></p>
<p style="color:white;"><b>Any person with disabilities who needs help accessing the content of the FCC Public file should contact Katie Bowman at <a href="mailto:kbowman@kstp.com">kbowman@kstp.com</a> or (651) 646-5555</b></p>
<p class="bold blue">
<a href="/article/stories/s277.shtml">Privacy Policy</a> | 
<a href="/article/stories/s2445183.shtml">Terms of Use</a> | 
<a href="/article/stories/s3198389.shtml">DMCA Notice</a> | 
<a href="/article/57/">Contest Rules</a> | 
<a href="/article/stories/s3285688.shtml">Site Map</a>
</p>
</div>
</div>


    <!-- End FCC Section -->
	<div class="row">
	<div class="col-xs-12 text-center">
	<p style="color:#fff;">
	This website is not intended for users located within the European Economic Area.<br />
	&copy; <script>document.write(new Date().getFullYear());</script> KSTP-TV, LLC<br />
	A Hubbard Broadcasting Company</p>
	</div>
	</div>
	<!-- End: FOOTER -->
</div>

        
</footer>
<script type="text/javascript">
  /********************************
   * FOR DEMO ONLY
   */
  $('a').on('click', function (e) {
    if ( $(this).prop('href') == '#') {
      e.preventDefault();
    }
  });
  /*********************************/
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"9e4de1d9fc","applicationID":"13487676","transactionName":"NlMEYhEFXkUEAEBdVw8ZM0QKS1VOBA5EWF0SGQ5ZDgEeRg0T","queueTime":0,"applicationTime":2,"atts":"GhQHFFkfTUs=","errorBeacon":"bam.nr-data.net","agent":"js-agent.newrelic.com\/nr-768.min.js"}</script>


	<!-- BEGIN: 2016-3rd-Party-Footer -->
<!-- Code Controlling the persistent ad -->
<div id="persistentBottomAd" class="mobile-ad-footer hideTheDiv" style="">
        <div id="ADSPACE07" class=""><script>googletag.cmd.push(function() {googletag.display('ADSPACE07');});</script></div>
</div>
<style>.hideTheDiv {display:none;}</style>
<script>
	if (theAllowTags.indexOf("ADSPACE07") > -1){
			$("#persistentBottomAd").removeClass("hideTheDiv");
			console.log('--> Display Persistent Ad');
	}
</script>
<!-- End -->
<!-- Begin Google Analytics -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-4427759-1', 'kstp.com');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');

</script>
<!-- End Google Analytics -->


<!-- Begin Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-cbzGBd7qrS9aE"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-cbzGBd7qrS9aE.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->


<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "15551634" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=15551634&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->


<!-- Begin AdCellerant -->
<div id="ttdUniversalPixelTag08616ab6335947cbb9b57746f5c4b4d2" style="display:none">
	<script src="https://js.adsrvr.org/up_loader.1.1.0.js" type="text/javascript"></script>
	<script type="text/javascript">
		(function(global) {
			if (typeof TTDUniversalPixelApi === 'function') {
				var universalPixelApi = new TTDUniversalPixelApi();
				universalPixelApi.init("gp5yvy1", ["rly48nk"], "https://insight.adsrvr.org/track/up", "ttdUniversalPixelTag08616ab6335947cbb9b57746f5c4b4d2");
			}
		})(this);
	</script>
</div>
<!-- End Adcellerant -->

<!-- END: 2016-3rd-Party-Footer -->
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5757269bf8dc7415"></script>
	
  
</body> 
</html>

